Download | Wiki

Feeder cannot work out which market condition to use


#1

Hi all, Im getting this error, is it normal?

[10:50:24 DBG] Price change ETH: NaN%
[10:50:24 ERR] Handled exception: Could not get ETH price change (60 mins) from
all exchanges.
[10:50:24 ERR] Returning a massive value so you end up in superbear
[10:50:24 DBG] Using ETH difference from 5:55:00 AM to 10:40:00 AM
[10:50:24 DBG] Price change ETH: -0.39%
[10:50:24 WRN] Could not work out which market condition to use. Using the last
one


#2

which ptf version are You using?


#3

pt-feeder-v1.6.0.855


#4

which exchange, os?
vps or local pc?


#5

Binance, Windows
VPS


#6

I can see some “problems” with binance…
how often you check market condition?
“MarketConditionCheckInMinutes” in hostsettings.json?

ie: my ptf current behaviour

0|PT2-Tok1 | 2018-06-11 13:23 +02:00: 2018-06-11 13:23:16 ERROR ProfitTrailerService - Error occured in OO, message ERROR: -1003, TOO MANY REQUESTS QUEUED., result:
0|PT2-Tok1 | 2018-06-11 13:23 +02:00: 2018-06-11 13:23:16 ERROR ProfitTrailerService - openOrders - nl.komtek.pt.utils.j: ERROR: -1003, TOO MANY REQUESTS QUEUED.
0|PT2-Tok1 | 2018-06-11 13:23:16 INFO GenericStrategyRunner - Cooling down for 1 minute
0|PT2-Tok1 | 2018-06-11 13:23 +02:00: 2018-06-11 13:23:20 INFO Util - Detected configuration changes
0|PT2-Tok1 | 2018-06-11 13:23 +02:00: 2018-06-11 13:23:31 INFO Util - Detected configuration changes
0|PT2-Tok1 | 2018-06-11 13:23 +02:00: 2018-06-11 13:23:37 INFO Util - Detected configuration changes
0|PT2-Tok1 | 2018-06-11 13:23 +02:00: 2018-06-11 13:23:59 INFO ProfitTrailerService - Cache Heartbeat
0|PT2-Tok1 | 2018-06-11 13:24 +02:00: 2018-06-11 13:24:16 INFO GenericStrategyRunner - We got temp banned. Waiting 5 minutes
0|PT2-Tok1 | 2018-06-11 13:29 +02:00: 2018-06-11 13:29:17 INFO AverageCalculator - Please set BNB_bought_price


#7

I dont have that setting in host settings


#8

My ptf is just repeating the same thing

[11:43:11 DBG] Not enough prices for ETH were returned from Bittrex
[11:43:11 DBG] Not enough prices for ETH were returned from Poloniex
[11:43:11 DBG] Not enough prices for ETH were returned from Binance
[11:43:11 DBG] Price change ETH: NaN%
[11:43:11 ERR] Handled exception: Could not get ETH price change (60 mins) from
all exchanges.
[11:43:11 ERR] Returning a massive value so you end up in superbear
[11:43:11 DBG] Not enough prices for ETH were returned from Bittrex
[11:43:11 DBG] Not enough prices for ETH were returned from Poloniex
[11:43:11 DBG] Not enough prices for ETH were returned from Binance
[11:43:11 DBG] Price change ETH: NaN%
[11:43:11 ERR] Handled exception: Could not get ETH price change (60 mins) from
all exchanges.
[11:43:11 ERR] Returning a massive value so you end up in superbear
[11:43:12 DBG] Using ETH difference from 6:45:00 AM to 11:35:00 AM
[11:43:12 DBG] Price change ETH: 0.21%
[11:43:12 WRN] Could not work out which market condition to use. Using the last
one


#9

then try to add in Host: section, with usually safe value 5 min
ie:
“SecurityToken”: “”, // Security Token for PT Feeder API endpoints
"MarketConditionCheckInMinutes": “5”, // How often to check for changes.
“CalculateTrailingValues”: “true”, // whether PT Feeder should calculate the trading values for you


#10

It looks like it was checking the market every “2” mins

Added that line anyway so now it’s every “5” mins


#11

See every 2 mins if you look at the times

[11:57:19 ERR] Returning a massive value so you end up in superbear
[11:57:19 DBG] Using ETH difference from 7:00:00 AM to 11:50:00 AM
[11:57:19 DBG] Price change ETH: 0%
[11:57:19 WRN] Could not work out which market condition to use. Using the last
one
[11:59:21 DBG] Not enough prices for ETH were returned from Bittrex
[11:59:21 DBG] Not enough prices for ETH were returned from Poloniex
[11:59:21 DBG] Not enough prices for ETH were returned from Binance
[11:59:21 DBG] Price change ETH: NaN%
[11:59:21 ERR] Handled exception: Could not get ETH price change (60 mins) from
all exchanges.
[11:59:21 ERR] Returning a massive value so you end up in superbear
[11:59:21 DBG] Not enough prices for ETH were returned from Bittrex
[11:59:21 DBG] Not enough prices for ETH were returned from Poloniex
[11:59:21 DBG] Not enough prices for ETH were returned from Binance
[11:59:21 DBG] Price change ETH: NaN%
[11:59:21 ERR] Handled exception: Could not get ETH price change (60 mins) from
all exchanges.
[11:59:21 ERR] Returning a massive value so you end up in superbear
[11:59:21 DBG] Using ETH difference from 7:00:00 AM to 11:50:00 AM
[11:59:21 DBG] Price change ETH: 0%
[11:59:21 WRN] Could not work out which market condition to use. Using the last
one


#12

2 min is too fast…
I’ve got those errors with 4 min setting…
so far it’s ok with 5 min interval


#13

Restarted everything added to “5” mins, same thing

[12:12:19 ERR] Returning a massive value so you end up in superbear
[12:12:19 DBG] Using ETH difference from 7:15:00 AM to 12:05:00 PM
[12:12:19 DBG] Price change ETH: 0.94%
[12:12:20 WRN] Could not work out which market condition to use. Using the last
one
[12:17:21 DBG] Not enough prices for ETH were returned from Bittrex
[12:17:21 DBG] Not enough prices for ETH were returned from Poloniex
[12:17:21 DBG] Not enough prices for ETH were returned from Binance
[12:17:21 DBG] Price change ETH: NaN%
[12:17:21 ERR] Handled exception: Could not get ETH price change (60 mins) from
all exchanges.
[12:17:21 ERR] Returning a massive value so you end up in superbear
[12:17:21 DBG] Not enough prices for ETH were returned from Bittrex
[12:17:21 DBG] Not enough prices for ETH were returned from Poloniex
[12:17:21 DBG] Not enough prices for ETH were returned from Binance
[12:17:21 DBG] Price change ETH: NaN%
[12:17:21 ERR] Handled exception: Could not get ETH price change (60 mins) from
all exchanges.
[12:17:21 ERR] Returning a massive value so you end up in superbear
[12:17:21 DBG] Using ETH difference from 7:20:00 AM to 12:10:00 PM
[12:17:21 DBG] Price change ETH: 0.3%
[12:17:21 WRN] Could not work out which market condition to use. Using the last
one


#14

Couple of other things.

Are you on windows? If so, can you try running http://www.timesynctool.com/ . Because none of the exchanges can be queries, it seems like either a time issue or a network problem.

Also, has it worked previously?


#15

Hi Mehtadone, yes it has been working okay up until today when I noticed the errors. I am running it on windows on a VPS.

Which version of Net Time should I use?


#16

VPS without a proper time from hypervisor?!


#17

@Coinzyyy the latest stable will be fine.

@JoeChip I’ve seen it quite often. Not sure why, but Windows VPS’s, especially on VirMach, drift.


#18

@mehtadone Im on Virmach it’s been okay for the past month no problems at all. I have installed Net Time, looks to be running okay no reported errors with it…


#19

@Coinzyyy So Nettime should sync the server time with the “real” time.

Can you try restarting PTF and see if you still get the error?


#20

Wait, I installed Net Time on my local machine