Download | Wiki

Getting ConfigApi - Received message from api: file size too big from profit trailer


#1

Whenever ptfeeder updates my config, profit trailer throws an error about:
ConfigApi - Received message from api: file size too big

This is with the latest pt feeder and profit trailer.


#2

When you say latest, do you mean the beta or version 1.6?

When there is a low min volume, and a lot of properties have been overridden, the config get too large for the PT API.

The beta has an option to reduce the comments ptf writes to help avoid this in the majority of occasions https://wiki.ptfeeder.co/beta.html#reduced-comments


#3

So no, I wasn’t using the beta. I am now though. It appears to have fixed the config file size. Only issue I’m having now is I can’t figure out how to lower my dust value :frowning:


#4

You can use BtcDust in the Common section of your PT Feeder appsettings file


#5

Thank you … I did find information about the Beta fix and also the one line to enter in the PT Feeder community but having issues getting the code syntax right: “PrintPairComments” : “false”, to enter that line in the host file right ? but where ? I am getting errors when I put it in the file and restart the feeder. Not a great code guy :smiley: … Also the PTF put PT in borring mode and now also see the following: STOCH_length empty, and SHORTTERMTREND_candle_per is empty ? So got three issues trying to clear up :smiley:


#6

“PrintPairComments” : “false”, This goes in your hostsettings.json file like so:

  "Host": {
    "ProfitTrailerFolder1": "",
    "ProfitTrailerApiEndPoint1": "", 
    "ProfitTrailerServerApiToken1": "",
    "HostName": "", 
    "LicenseKey": "", 
    "PrintPairComments" : "false",
"

STOCH_length empty, and SHORTTERMTREND_candle_per is empty - This means you are missing some indicators in the common section of your appsettings.json file. I’m not sure what SHORTTERMTREND is. That seems to be a custom indicator in your settings but Stoch length is probably missing this one:

 "Common": {

    "IndicatorsStochLength": "14",

  },

#7

Hi,

I am still having shose file to big errors,
change the hostsettings file with “PrintPairComments” : “false”,
running PTfeeder 1.7 and FerryHendriks settings from sept.
removed many comments.


#8

Hi,

Unfortunately then there is nothing else we can do from a PT Feeder side to stop that.

You’ll have to go through the appsettings and streamline it so less pair specific properties are written.