Download | Wiki

Pt-feeder not starting, says API key is not valid


#1

So this is very odd, as my pt-feeder was working I had to reboot my bot PC.

After which my 2 Bittrex Bots started fine PT & PT-feeder.
But my 2 Binance bots I could only get PT working as the pt-feeder says one of my API keys was not valid.

So I checked Telegram pt-feeder licence bot and sure enough I have 4 API keys in there 2 for Bittrex and 2 for Binance and they are the default keys so should be fine, but I keep getting the API key error.

Thinking it needed an upgrade I installed the latest pt-feeder and I still get the same error.


#2

Can you paste the full error? Sometimes there is another error above the invalid API error which is the real reason why feeder didn’t start.


#3

And in hostsettings.json you have pt feeder license key?
(not exchange api key)


#4

Thanks for chipping in chaps, all looks goon in the settings files, as I say it was working before I did a reboot and nothing has changed.

Odd thing is I tested it again this morning and its working!

Could the licence server that checks APIs have been down?


#5

Potentially, but we do get an alert when the license server goes down and nothing came through.

I’ll look through the logs from yesterday to see if I can spot anything. But glad its working now.